Midnight Plug-in Suite 1.5

A plug-in suite that includes two of the most iconic Focusrite modules of all time – the ISA110 equalizer and ISA130 compressor
The Midnight Plug-in Suite uses powerful DSP technology to efficiently model sounds.

This unique feature gives them elegant, functional on-screen front panels that make them simplicity itself to use. Now you can add that authentic, classic Focusrite sound to your own tracks at a price you can afford. Your productions have never sounded so good.
 
The ISA110 and 130 modules, created for the legendary Forté console in the 1980s, represent the epitome of Focusrite analogue audio processing, and performed a vital role in the making of literally thousands of hit records – they still change hands for thousands today.

Their new digital incarnation in the Midnight suite for AU, VST and RTAS gives them stunning new hi-def on-screen front panels so realistic you’ll believe you can grab a knob with your fingers. In fact, of course, you can tweak them with a click and a drag of the mouse, or graphically edit the response curves.

But whichever way you want to go, behind each exquisite graphic front-panel lies powerful DSP code that exactly models the original analogue processors that inspired the Midnight suite, with all the warmth, clarity, control and incredible sound of those original analogue designs.

Main features:

  • Powerful DSP modelling
  • Legendary audio quality
  • Exquisite high-definition graphic user interface
  • The sound at the heart of the digital studio

last updated on:
February 3rd, 2014, 19:20 GMT
file size:
20.2 MB
price:
FREE!
developed by:
Focusrite
license type:
Freeware
operating system(s):
Mac OS X
binary format:
Universal Binary
category:
Home \ Audio

FREE!

In a hurry? Add it to your Download Basket!

user rating 1

4.0/5
 

0/5

Rate it!
3 Screenshots
Midnight Plug-in SuiteMidnight Plug-in SuiteMidnight Plug-in Suite
What's New in This Release:
  • Fixes a problem where deleting plug-ins can cause Live 8 to crash
  • Fixes a problem where plug-ins can incorrectly require re-authorization
read full changelog

Add your review!

SUBMIT