Mozilla Blocks Old Versions of Silverlight Plugin for Mac OS X

Versions under 5.1 branch cause serious stability problems in Firefox

By on August 23rd, 2012 09:50 GMT

Mac users with an outdated Silverlight in Firefox are currently unable to use the plugin as Mozilla took the decision to block all versions under the 5.1 branch. The reason for this is that older versions of the Silverlight for Mac OS X are at the root of serious stability issues in Firefox.

The fix is an easy one, though, because all you have to do is get the latest version of Silverlight plugin. You can check if you have an outdated installation on this page.

Among the issues caused by the outdated plugin, there is a crash in Hotmail, but a multitude of other problems should be corrected once Silverlight is updated to release 5.1. However, these do not include the quirk with Netflix, which is under investigation at the moment.

Silverlight for Mac is available for download from here.
Download Firefox for Mac

4 Comments